Power Outage in Area of Plant
Incident Report for LukStats
Resolved
The power has been restored!
Posted Aug 06, 2022 - 19:19 CEST
Identified
due to an power outage in the area of plant currently all systems are unavailable.
Posted Aug 06, 2022 - 18:13 CEST
This incident affected: lukhelp.com, lukdocs.com, and lleu.org.